Ad

Sunday, December 29, 2019

Convert Tensorflow 1.0 to Tensorflow 2.0


  • Specify Tensorflow version in Google Colab `%tensorflow_version 2.x`. It is not recommended to use pip install in Google Colab: quote "We recommend against using pip install to specify a particular TensorFlow version for GPU backends. Colab builds TensorFlow from source to ensure compatibility with our fleet of GPUs. Versions of TensorFlow fetched from PyPI by pip may suffer from performance problems or may not work at all." 
  • Check tensorflow version after installing `import tensorflow` `print(tensorflow.__version__)`
  • TPU for Tensorflow 2.0 is not yet available. "TPUs are not fully supported in Tensorflow 2.0. We expect they will be supported in Tensorflow 2.1. Follow along on GitHub."

5 comments:

Handling Imbalanced Dataset in Machine Learning

Imbalanced dataset can affect machine learning decision boundaries. Distribution of target class matters! Why is imbalanced class bad - ...