Ad

Thursday, April 28, 2022

Error Message Hardhat debugging error unsupported engine hardhat, current node v18

Error message

npm WARN EBADENGINE 

Unsupported engine {

package: 'hardhat@2.9.3',

required: { node: '^12.0.0 || 14.0.0 || 16.0.0' }

current: { node: 'v18.0.0', npm: '8.6.0' }

}

Uniqtech

 

It may be surprising that to use the latest smart contract development tool Hardhat, you will need to use an older version of Node.js, NOT the current node.js 18. Revert it to node 12, 14, 16.



No comments:

Post a Comment

Data analysis

Data visualization of common math formula.